Important
Technical Support for older products: SuperVoice 2.7 or earlier, SuperFax  8 or earlier and SuperVoice Pro 7.0 or earlier is no longer available as they are not compatible with newer operating systems.
SuperVoice 2.2, SuperFax 6 are not compatible with Windows XP or later operating systems.

SuperVoice 2.6 or earlier, SuperVoice Pro 7 or earlier, SuperFax 7.0 or earlier are not compatible with Windows Vista or Windows 7 operating systems.

SuperVoice 2.8 or earlier, SuperVoice Pro 9 or earlier, SuperFax 10.0 or earlier are not compatible with Windows 8 operating systems.

We recommended upgrading to one of our current products i.e.:
SuperVoice 3.0, SuperVoice Pro 11, Network Superfax 9 or SuperFax 11.

If you have any questions, please feel free to contact us.

Technical Support
IMPORTANT ANNOUNCEMENTS:
To save time
  1. Download the latest update of your product from our Update Section
    Check also if you have the latest modem driver for your modem installed.
    Click here for links to various sites of Modem & pc manufacturers.
  2. Check the Frequently asked questions for your product
    Click here for the FAQ for Network SuperFax
    Click here for the FAQ for SuperVoice
    Click here for the FAQ for SuperFax
    Click here for the FAQ for SuperVoice Pro
  3. If this does not resolve any issues you might have, you can  contact  Technical support by going to our :
    Online Technical Support Form
    Please note that we cannot offer technical support by telephone.
     

When contacting us, please include as much information as possible about your computer, operating system and modem.


 
Contact |Terms and Conditions